[Interfaces/Portal] Public links cannot be accessed

Incident Report for Pipefy

Postmortem

Root Cause

A recent update to the token generation service aimed at enhancing performance inadvertently caused issues with public links. The update did not account for the public interface scenario, leading to accessibility problems.

Resolution

The problematic deployment was removed to resolve the incident. A rollback was executed, and the changes were reverted to restore normal functionality.

Action Plan

We are improving the code and enhancing test coverage, including both manual and automated tests. Additionally, we are expanding end-to-end test coverage for these scenarios and creating logs to monitor this situation.

Posted Sep 05, 2025 - 14:33 UTC

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 21:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 21:15 UTC

Identified

It is not possible to access the portal's public links and interfaces
Posted Aug 19, 2025 - 21:13 UTC
This incident affected: Features (Portals).