Create cards via email feature is not creating cards.
Incident Report for Pipefy
Postmortem

Summary:
Create cards via email Feature was not creating cards

Impact:
Minor

Detection:
Customers started to complain that they sent the email and didn’t see any card created

Root Cause:
A misconfiguration during the maintenance window to migrate our database, which turned off a trigger, important to Inbox Email feature works properly. All the emails were received successfully but not processed correctly.

Resolution:
We identified and reactivate the trigger on the database, identified all the emails that should create a card and re-processed them all.

Posted Nov 13, 2019 - 20:51 UTC

Resolved
All the emails since Yesterday have been successfully processed.
Posted Nov 11, 2019 - 21:04 UTC
Monitoring
The fix has been deployed and the feature has been enabled.
We will keep monitoring the feature as we have a high volume of emails to be processed. ETA : 3 hours to process all emails.
Posted Nov 11, 2019 - 18:00 UTC
Update
We deployed the fix and now we are working to process the emails sent from Yesterday until Today before enable the feature again.
Posted Nov 11, 2019 - 17:35 UTC
Identified
We identified the issue in a database trigger and we are deploying the fix.
Posted Nov 11, 2019 - 17:04 UTC
Update
We still investigating what is causing the issues with Inbox Email feature
Posted Nov 11, 2019 - 16:39 UTC
Update
We noticed emails are being received by pipefy, but it is not creating the cards correctly. We turned off the worker that process this feature to avoid more issues until we solve the degradation.
Posted Nov 11, 2019 - 16:04 UTC
Investigating
We are currently investigating this issue.
Posted Nov 11, 2019 - 14:51 UTC
This incident affected: Components (Email inbox).