SOme users might not be able to login
Incident Report for Pipefy
Postmortem

Root Cause

Some users were unable to log in because their accounts or IPs were flagged by an overly strict rule that blocked access based on shared IP usage.

Resolution

The restrictive rule was disabled to restore access, resolving the login issue.

Action Plan

The team refined the rule to better align with expected behavior and is monitoring its effectiveness to reduce false positives. They are also improving error handling, organizing a workshop on platform security, and evaluating ways to enhance privacy for specific attack vectors.

Posted Dec 04, 2024 - 19:10 UTC

Resolved
We have successfully updated our internal settings, and users are now able to log in again. More detailed information about the case will be provided in the post-mortem.
Posted Dec 03, 2024 - 00:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2024 - 23:31 UTC
Monitoring
We noticed some users might have faced login redirects to a block page with the message "The owner of this website has banned you temporarily". We have updated our settings internally and are monitoring the results.
Posted Dec 02, 2024 - 21:11 UTC
This incident affected: Authentication.