AI Analytics slowness

Incident Report for Pipefy

Postmortem

Root Cause

The AI Analytics feature experienced a complete failure, causing the system to hang in a 'processing' state without returning results. This issue arose after a deployment implemented

Resolution

The problem was resolved by implementing a fix to address the system's failure. This action restored the functionality of the AI Analytics feature, allowing it to process queries and return results as expected.

Action Plan

To prevent future incidents, we will enhance tests to better identify failures, Conduct post-implementation tests and improve the telemetry monitoring for the AI analytics feature.

Posted Dec 08, 2025 - 15:45 UTC

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 15:08 UTC

Investigating

The team identified an issue and still working on solution
Posted Nov 28, 2025 - 15:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 28, 2025 - 14:59 UTC

Investigating

We are currently investigating this issue.
Posted Nov 28, 2025 - 14:50 UTC
This incident affected: Features (AI Assistant).