Automations Slowness

Incident Report for Pipefy

Postmortem

Root Cause

The system experienced slowness due to multiple updates being processed simultaneously, which led to delays and a backlog of tasks. This was caused by bulk actions affecting the same field.

Resolution

To prevent further issues, we isolated the affected processes into a dedicated queue, ensuring that any high volume or problems would not impact other users. Additionally, we adjusted the number of workers to manage the load effectively.

Action Plan

We moved the affected processes to a specialized queue and reduced the number of workers to handle tasks more efficiently. We also reviewed logs to identify the cause of the backlog and are considering setting limits and prioritization queues. Further actions include enhancing logging for better issue identification and potentially redesigning the process for improved performance.

Posted Oct 02, 2025 - 20:36 UTC

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 16:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 15:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 25, 2025 - 14:49 UTC

Investigating

We are currently investigating this issue.
Posted Sep 25, 2025 - 14:22 UTC
This incident affected: Features (Automation).