It is not possible to export reports, via downloads or email
Incident Report for Pipefy
Postmortem

Root Cause

The reports stopped generating because we hit a limit in our data system. This happened because we didn't close the data search when an error occurred. The error was due to a problem with how numbers were being read, as some fields were text and not numbers, causing the search to remain open.

Resolution

We increased the data search size. Additionally, we reverted the code to a previous version.

Action Plan

We configured Elasticsearch to handle report data and will implement specific monitoring for reports.

Posted Aug 06, 2024 - 11:30 UTC

Resolved
The incident has been solved. Within two business days, we will publish the postmortem data along with the corrective actions to be implemented.
Posted Aug 01, 2024 - 12:25 UTC
Monitoring
We have successfully rolled back the code responsible for the failure, resolving the issue with exports. As a result, exporting reports is now functioning normally. We are actively monitoring the situation to prevent any further incidents.
Posted Aug 01, 2024 - 12:13 UTC
Update
We performed an update, and some exports started working again. We are working on a definitive solution.
We will give an update within 20 minutes.
Posted Aug 01, 2024 - 12:07 UTC
Update
We have already identified the root cause and are working on the solution. We will give a new update within 20 minutes
Posted Aug 01, 2024 - 11:54 UTC
Identified
Our functionality to export reports is not working, either by download or by email. We don't have any workaround for this at the moment.
Posted Aug 01, 2024 - 00:04 UTC
This incident affected: Reports.