Users aren't able to access emails from cards
Incident Report for Pipefy
Postmortem

Root Cause

There were some recent changes in or code that didn't have some corner case scenarios mapped on the testing section, and as this scenario wasn't previously mapped/tested, we were surprised by the error.

Resolution

We added a part to our code that maps this specific scenario, and thus, we'll prevent future errors like this.

Action Plan

For every corner case scenario we cannot map when developing, we'll create a documentation about it, and so we can prepare our developers to foresee issues like this, and so the application will be safer from errors.

Posted Dec 20, 2023 - 17:17 UTC

Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 14:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2023 - 14:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 19, 2023 - 14:34 UTC
This incident affected: Apps (Email messaging).