Pipefy is experiencing slowness, and our engineers are already working on it.

Incident Report for Pipefy

Postmortem

Root Cause

An Airflow task ran a database query without necessary filters, causing the system to become overloaded. This led to multiple attempts to execute the same heavy query simultaneously, which significantly impacted the database's performance and availability.

Resolution

The problematic queries were identified and stopped manually at the database level to alleviate the overload and restore normal operations.

Action Plan

Since this was a unique and isolated incident, no further actions are planned. The situation is considered unlikely to happen again.

Posted May 13, 2025 - 21:28 UTC

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 19:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 19:16 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 19:16 UTC

Investigating

We are currently investigating this issue.
Posted Apr 24, 2025 - 19:06 UTC
This incident affected: Application.