Custom Integrations/iPaaS : Rate Limiting Issues

Incident Report for Pipefy

Postmortem

Root Cause

Recently, efforts were made to separate the infrastructure for better handling of increased demand. This led to the failure of previously set exception rules. An update was applied to a specific host or domain without verifying its use in the integration, causing issues.

Resolution

The issue was resolved by modifying the configuration rules on Ipass app.

Action Plan

  • An anomaly alert will be created for the Ipass to avoid this scenario happend again in the future
Posted Apr 06, 2026 - 19:32 UTC

Resolved

This incident has been resolved.
Additional information will be provided shortly in our postmortem report.
Posted Apr 02, 2026 - 14:23 UTC

Monitoring

We have identified that a recent internal infrastructure update caused unexpected rate-limiting on our iPaaS platform, resulting in temporary delays or 429 errors in workflows for the custom integrations.

Our Infrastructure team has identified the root cause and successfully applied a fix to restore normal traffic. We're closely monitoring the environment to ensure stability. Normal service operation is expected across all affected organizations.
Posted Apr 01, 2026 - 19:40 UTC
This incident affected: Apps (Integrations).