Pipefy might be inacessible for some users
Incident Report for Pipefy
Postmortem

Root Cause

The database health check failed, prompting an automatic failover that unfortunately did not execute as anticipated. As a result, an unplanned service downtime occurred.

Resolution

To resolve the issue, system adjustments were made to manage database connections and ensure a smooth transition to a new master node.

Action Plan

Improve system monitoring with additional metrics for better oversight. Adjusted the health check and failover parameters.

Posted May 08, 2024 - 14:33 UTC

Resolved
This incident has been resolved.
Posted May 03, 2024 - 19:37 UTC
Monitoring
A fix has been applied to resolve the outage and Pipefy is now available to all users.
Posted May 03, 2024 - 19:12 UTC
Update
The technical team is still working to restore full access to all users as quickly as possible. Some user might still experience degraded performance.
Posted May 03, 2024 - 19:05 UTC
Update
The technical team is still working to restore full access to all users as quickly as possible.
Posted May 03, 2024 - 18:44 UTC
Update
The technical team is still working to restore full access to all users as quickly as possible.
Posted May 03, 2024 - 18:25 UTC
Identified
The technical team has identified the causes of the system unavailability and is currently working to restore full access to all users as quickly as possible.
Posted May 03, 2024 - 18:05 UTC
Update
We are continuing to investigate this issue.
Posted May 03, 2024 - 17:58 UTC
Investigating
We are currently investigating this issue.
Posted May 03, 2024 - 17:53 UTC
This incident affected: Application.