Issue with Filters in Databases

Incident Report for Pipefy

Postmortem

Root Cause

The issue was caused by a non-optimized query that struggled when handling more than 50 records, leading to problems in database searches.

Resolution

The problem was resolved by applying a revert to address the issue.

Action Plan

To prevent similar issues in the future, unit tests will be created to avoid this type of failure scenario.

Posted Jan 13, 2026 - 17:23 UTC

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 14:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 14:02 UTC

Investigating

We have identified an issue where some records might not be visible when searching with filters in databases.
Posted Jan 09, 2026 - 14:02 UTC
This incident affected: Features (Filters).