Custom Integrations | Slowness when executing any action

Incident Report for Pipefy

Postmortem

Root Cause

The issue was caused by exceeding the execution limit in integration queues, leading to a loop in automation that triggered numerous webhooks. This resulted in an overload of a specific flow, creating a large processing queue. Consequently, clients experienced delays in their process executions.

Resolution

To resolve the issue, the customer service account was deactivated, which helped alleviate the problem.

Action Plan

To prevent future occurrences, a rate limit will be activated on the system, and the timeout for execution flows will be reduced.

Posted Mar 02, 2026 - 21:16 UTC

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 15:56 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 25, 2026 - 15:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 14:50 UTC

Investigating

We are currently investigating this issue.
Posted Feb 25, 2026 - 14:32 UTC
This incident affected: Apps (Integrations).