Service Instability
Incident Report for Pipefy
Resolved
This degradation was resolved and all components and features are back to its normal state.
Posted Jul 23, 2019 - 18:35 UTC
Update
We monitored the platform for up to 40 minutes without any issues. This degradation is now resolved.
Posted Jul 23, 2019 - 17:54 UTC
Monitoring
The fix for the Lateness was shipped to Production. There should be no more problems related to this.

Also, the SMTP and Email Templates were back to normal without no interaction from the Engineering team. Maybe a queue on the third-party that provides mailing services to Pipefy was with a huge volume. We will keep investigating this for the root cause to be defined.
Posted Jul 23, 2019 - 17:53 UTC
Update
We continue to look for the root cause of the Email Templates and SMTP and as soon as we have an update we will post here.
Posted Jul 23, 2019 - 16:50 UTC
Identified
Root cause related to the ̈lateness ̈ was found out. Its is related to a specific trigger on the database. A fix for the problem is being shipped to Production right away. We will update as soon as it is deployed.
Posted Jul 23, 2019 - 16:15 UTC
Update
The Engineering team is currently investigating this.
Posted Jul 23, 2019 - 15:35 UTC
Investigating
The Engineering team noticed some instability with any feature or action that depends of the ̈lateness ̈ state on Pipefy platform.

SMTP (normal and custom) and Email Templates features on Pipefy platform are also intermittent and not working properly.
Posted Jul 23, 2019 - 15:29 UTC
This incident affected: Apps (Email messaging, Email template) and Components (Lateness).