Failure on personal acess token

Incident Report for Pipefy

Postmortem

Root Cause

A critical incident occurred due to a strategic update aimed at resolving security issues related to email feature. This incident affected key processes, including Integrations and AI automations, leading to failures in customer workflows.

Resolution

To resolve the issue, the team had to reverse the changes and execute a script to restore user accounts. This action was necessary to ensure the stability and functionality of the affected users.

Action Plan

  • Future actions include setting up alerts for agent requests and specific error codes
  • Understanding the limitations of current alerts to be more proactive on this scenarios
  • Improve tests scenarios for cacth error previously
Posted Dec 18, 2025 - 20:32 UTC

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 15:33 UTC

Update

The team is working on script to running to the personal accounts that did not log in for the past 90 days
Posted Dec 18, 2025 - 15:29 UTC

Investigating

We identified that some personal acess token are experience some issue, we already working on this fix
Posted Dec 18, 2025 - 15:00 UTC