API parameter update.field.value, phase form and start form is not working properly

Incident Report for Pipefy

Postmortem

Root Cause

Users experienced issues with our API due to a mismatch between the database function version and the code version. The discrepancy in data type definitions caused the malfunction.

Resolution

The issue was resolved by rolling back the function version to a previous state, which restored proper functionality to the API.

Action Plan

We plan to review and address database transactions within the code, develop a strategy for managing these transactions, and ensure consistency between production and development environments. Additionally, alerts will be created to identify related errors, and the feasibility of running tests post-migration will be assessed.

Posted May 02, 2025 - 15:09 UTC

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 17:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2025 - 17:33 UTC

Identified

A database update this morning caused an issue with the API. A manual revert to a previous version with the correct schema was completed, and the issue has been resolved.
Posted Feb 26, 2025 - 17:32 UTC

Investigating

Some users were unable to use the update.field.values parameter from our API, as well as phase forms or start forms.
Posted Feb 26, 2025 - 14:45 UTC
This incident affected: API (GraphQL).