SMTP configuration using Gmail is not working
Incident Report for Pipefy
Postmortem

Root Cause

Updates on external servers had params that weren't mapped by our program, which led to this issue.

Resolution

We've manually mapped all the routes to ensure the feature will be working, and we'll be monitoring it from now on.

Action Plan

Posted Mar 21, 2024 - 15:31 UTC

Resolved
The system instability on SMTPs with Gmail hosts has been fixed and the performance of the platform has been restored.
As soon as the investigation process is over, we’ll share further details about the causes.
Posted Mar 20, 2024 - 01:06 UTC
Update
Pipefy’s technical team is still investigating the causes of the SMTP configuration of Gmail degraded. A final diagnosis is still to be
established. We will bring new updates in about 6 hours from now.
Posted Mar 19, 2024 - 23:21 UTC
Update
We're continuing investigating to find the route cause of this issue.
Posted Mar 19, 2024 - 22:23 UTC
Update
We're still investigating to find the route cause of this issue.
Posted Mar 19, 2024 - 21:46 UTC
Update
We're remain investigating to find the route cause of this issue.
Posted Mar 19, 2024 - 21:14 UTC
Update
We're still investigating the cause
Posted Mar 19, 2024 - 20:40 UTC
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 20:05 UTC
Investigating
Customers with a custom SMTP configured with Gmail are unable to send emails. We are analyzing to identify and correct the error as soon as possible
Posted Mar 19, 2024 - 18:46 UTC
This incident affected: Components (Email inbox).