Some users may be unable to access Pipefy.

Incident Report for Pipefy

Postmortem

Root Cause

Last Sunday, there was an issue with the database cluster due to a key rotation process. The Postgres operator rollout was not executed during the key rotation. Later, Kubernetes initiated the rollout, which led to the failover of the database instances. This caused some users to be unable to access Pipefy.

Resolution

The failover process, which is a built-in feature of the database cluster, had to be completed without interruption. The total downtime experienced was 4 minutes.

Action Plan

No immediate action was taken during the incident, as it was expected. However, the necessary actions should have been performed during the scheduled maintenance window on Sunday.

Posted May 02, 2025 - 15:06 UTC

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 19:56 UTC

Identified

Some users may be experiencing slowness and difficulty accessing Pipefy. We have identified the issue and are working to fix it as quickly as possible.
Posted Apr 10, 2025 - 19:44 UTC
This incident affected: Application.