E-mails being blocked by Spamhaus

Incident Report for Pipefy

Postmortem

Root Cause

Some organizations faced email delivery issues due to their emails being blacklisted. This was caused by certain IPs being blocked, which affected the ability to send emails.

Resolution

The issue was mitigated by removing the problematic IP from the range, allowing emails to be sent through other available IPs. Additionally, a support ticket was opened to resolve the IP block.

Posted Nov 11, 2025 - 18:09 UTC

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 16:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 15:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 31, 2025 - 15:27 UTC

Investigating

We are currently investigating this issue.
Posted Oct 31, 2025 - 15:21 UTC
This incident affected: Features (Email Messaging).