Pipefy down
Incident Report for Pipefy
Postmortem

Root Cause

The primary database server encountered a memory issue, which triggered a recovery process. After the expected recovery time of 10 minutes, a system operator initiated a transfer to a backup server to restore functionality.

Resolution

Once the recovery time elapsed, the system operator successfully switched the operations to a backup server, ensuring the service was restored and operational.

Action Plan

The recovery time will be reduced to 3 minutes to minimize downtime in the future. Additionally, the database service monitoring will be enhanced to ensure prompt alerts in similar situations.

Posted Dec 04, 2024 - 18:58 UTC

Resolved
Pipefy was down (01:54 PM to 02:09 PM) for most of our customers.
Now the application is normalized. The RCA is yet to be finished, we'll post more details further on our Post-Mortem.
Posted Dec 01, 2024 - 01:30 UTC