Date fields showing in an incorrect format in public forms

Incident Report for Pipefy

Postmortem

Summary

Data fields within the platform were displaying incorrect formats, which specifically affected forms accessed by logged-in users. This issue was identified and resolved without causing the platform to become inaccessible.

Impact

The incorrect data formats impacted the user experience for those who were logged into the platform, potentially causing confusion or errors in form submissions. However, the platform remained accessible, ensuring that users could continue to perform other tasks without interruption.

Root Cause

The root cause of the issue was traced back to a merge request in the app, where the correct configuration was not implemented. This oversight led to the incorrect data formats being displayed.

Corrective Actions

The issue was resolved by applying a merge request to revert the changes that caused the problem.

Next Steps | Conclusion

We will maintain vigilant monitoring of the system to ensure ongoing stability and to prevent future occurrences of similar issues. Our commitment to enhancing the customer experience remains a top priority as we continue to refine and improve our platform.

Posted Dec 09, 2025 - 22:09 UTC

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 20:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2025 - 20:47 UTC

Identified

Date fields are showing in an incorrect format in public forms.

Currently, the issue has been identified and a fix is being implemented.
Posted Dec 01, 2025 - 19:14 UTC
This incident affected: Application and Features (Public Form).