Outdated data

Incident Report for Pipefy

Postmortem

Root Cause

The system experienced delays due to multiple updates happening simultaneously in the same area, which led to slower performance and a backlog of tasks.

Resolution

To prevent further issues, we separated the affected processes into a dedicated queue. This ensures that any high volume or problems will not affect others. We also adjusted the number of active workers to manage the load better.

Action Plan

We moved the affected processes to a specialized queue and reduced the number of workers to handle tasks more efficiently. We also reviewed logs to identify the cause of the backlog and are considering setting limits and prioritization queues. Further actions include enhancing logging for better issue identification and potentially redesigning the process for improved performance.

Posted Oct 02, 2025 - 21:10 UTC

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 23:30 UTC

Identified

We are investigating an issue where customers may see outdated data between 17:50 and 19:30 GMT-3. Our team is working on it.
Posted Sep 18, 2025 - 23:02 UTC