Cards are not beeing created by the pipe email

Incident Report for Pipefy

Postmortem

Summary:

The issue at hand involved the inability to create cards via the pipe email in Pipefy. This was due to a rule on firewall provider that was inadvertently blocking incoming emails, which are essential for the automatic creation of cards. 

 

Impact:

The impact of this issue was significant as it disrupted the workflow of users relying on email-triggered card creation. This could have led to delays in task management and project tracking, affecting overall productivity and efficiency for users who depend on this feature for seamless operations.

 

Root Cause:

The root cause of the problem was identified as a specific rule on Cloudflare that was blocking incoming emails. This blockage prevented the emails from reaching the system, thereby halting the automatic card creation process.

 

Corrective Actions:

  • The team disabled the problematic rule on Cloudflare, which restored the normal flow of incoming emails and resumed the card creation process. - A ticket was opened with SendGrid to request a range of IP addresses to ensure smoother operations in the future. - An alert system is to be created to monitor the incoming emails from the SendGrid endpoint to prevent similar issues.

 

Next Steps/Conclusion:

We will continue to monitor the system closely to ensure stability and prevent future occurrences of similar issues. Our ongoing efforts are focused on enhancing the customer experience by ensuring that all features function seamlessly and efficiently.

Posted Mar 10, 2026 - 21:15 UTC

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 17:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 17:01 UTC

Investigating

Hello Pipefy customers!

We've identified a slowdown in receiving emails for card creation; during our analysis, we determined the slowness was due to our email provider. A ticket has been opened with our partner, and we are working to resolve the issue as quickly as possible.
Posted Feb 12, 2026 - 15:16 UTC
This incident affected: Features (Email Inbox).