Service Account Instability

Incident Report for Pipefy

Postmortem

Root Cause

A critical incident occurred due to a strategic update aimed at resolving security issues related to email feature. This incident affected key processes, including Integrations and AI automations, leading to failures in customer workflows.

Resolution

To resolve the issue, the team had to reverse the changes and execute a script to restore user accounts. This action was necessary to ensure the stability and functionality of the affected users.

Action Plan

  • Future actions include setting up alerts for agent requests and specific error codes
  • Understanding the limitations of current alerts to be more proactive on this scenarios
  • Improve tests scenarios for cacth error previously
Posted Dec 18, 2025 - 19:26 UTC

Resolved

Pipefy's customers

Today, December 18th, at 02:00 am until 10:00 am we had a critical incident that impacted some important processes such as integrations, agents 2.0, and AI automations. During this period, AI automations on customers flow failed and could impact critical processes. After the issue was detected, our team took the actions to resolve the problem, reducing customer impact.

Incident period

December 18th from 02:00 am to 10:00 am UTC -3

Impact

All processes on integrations, agents 2.0, and AI automations were severely impacted.

How to fix

Due to this incident, some integrations did not work properly at that time and need some manual actions.
A manually trigger in the Workato recipes is required, so things get back to work, as well as on the integrations configured in IPaaS. For AI automations, to ensure all processes run correctly, they must be initiated again.

Conclusion

We will continue to monitor the system closely to ensure stability and prevent future issues.
We also inform that our team is working to identify the root cause and will communicate as soon as possible in our Statuspage.

We totally understand the impact caused by the incident and are available for any questions or help.
Posted Dec 18, 2025 - 12:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 18, 2025 - 12:47 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 18, 2025 - 12:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 18, 2025 - 11:55 UTC