Slowness in filtering and generating reports

Incident Report for Pipefy

Postmortem

Root Cause

We experienced issues with several nodes in a specific data center, leading to slow performance and intermittent access to reports.

Resolution

The affected nodes were replaced with new ones to restore normal operations.

Action Plan

Since the issue originated from the data center provider, no preventive actions can be taken on our side.

Posted May 27, 2025 - 14:59 UTC

Resolved

This incident has been resolved.
Posted May 14, 2025 - 15:24 UTC

Monitoring

The maintenance has been successfully completed and the fix has been applied. The platform is now stable, and we are actively monitoring to ensure everything remains operational.
Posted May 14, 2025 - 02:24 UTC

Identified

Our infrastructure team will perform maintenance today at 23:00 UTC to address the slowness issue and improve overall performance. We’ll provide further updates as the work progresses.
Posted May 13, 2025 - 22:42 UTC

Investigating

We are currently experiencing performance issues that may impact some users when filtering data or generating reports within Pipefy.
Our engineering team has identified the cause and is working on a fix.
We will provide updates as progress is made.

Thank you for your understanding and patience!
Posted May 13, 2025 - 20:18 UTC
This incident affected: Features (Filters, Reports).