Latency in AI Automations and Intermittent Issues in AI Analytics

Incident Report for Pipefy

Postmortem

Root Cause

The issue was caused by an automation that inadvertently triggered a series of events, leading to a loop. This loop resulted in repeated automation triggers, causing delays and intermittent problems in the system's AI functionalities.

Resolution

To resolve the issue, the automations involved in the loop were deactivated, effectively stopping the cycle and restoring normal operations.

Action Plan

Moving forward, several measures will be implemented to prevent similar incidents. These include validating hypotheses to avoid impacts, setting rate limits, creating an emergency stop mechanism, and establishing alerts to indicate when this mechanism should be activated.

Posted Aug 15, 2025 - 11:39 UTC

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 14:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 13:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2025 - 13:42 UTC

Investigating

We are currently investigating this issue.
Posted Jul 29, 2025 - 13:32 UTC
This incident affected: Application.