Resolved
This incident has been resolved.
Investigating
Dear customer
With the goal of providing transparency regarding failures and incidents that may impact our customers, we would like to inform you that we had an integration incident that may have impacted our customers' experience.
The event was short but may have impacted some flows that ran on May 28, 2026, from 8:40 AM to 8:57 AM.
If you had any integration jobs fail during this specific window, you can now safely retry them.
The root cause is still being investigated and will be available soon.