Write-up published
Resolved
Root Cause
Frontend issues involving code incompatibility with Safari browser.
Resolution
Rollback + Code Fix avoiding the incompatible feature used previously.
Action Plan
Analyze better ways to improve validation of browser compatibility during or after development.
Resolved
This incident has been resolved.
Investigating
We are continuing to investigate this issue.
Investigating
We are currently investigating this issue.