Root Cause
After the upgrade, the new version failed to use the replication slot.
Resolution
A script was executed to correct the data for the period it was unavailable.
Action Plan
During the incident, a correction script was updated and run.